User Tools

Site Tools


metamos_installation

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
metamos_installation [2017/03/24 08:25]
hyjeong
metamos_installation [2017/03/24 08:38] (current)
hyjeong
Line 18: Line 18:
   CentOS release 6.8 (Final)   CentOS release 6.8 (Final)
  
-Linuxbrew를 설치하려면 최소한 development tool(yum groupinstall "​Development tools"​)과 ruby는 미리 깔려 있어야 한다. Linuxbrew 홈페이지를 참조하여 설치를 한 다음 brew doctor를 실행하니 git를 업데이트하라는 메시지가 나온다. brew install git를 하면 glibc, binutils 등 git가 의존하는 패키지가 자동적으로 설치될 것이다. 다음으로는 공식 문서에서 요구하는 prerequisite인 java(6+), perl(5.8.8+),​ python(2.7.3+),​ R(2.11.1+ with PNG support), gcc(4.7+), curl 및 wget이 설치되어 있는지 확인하라. gcc -v를 실행하면 linuxbrew를 통해서 5.3.0이 설치되었음을 확인할 수 있다. 현재 내가 쓰는 서버의 패키지 설치 상황은 [[my_brew_list|여기]]를 참조하라.+Linuxbrew를 설치하려면 최소한 development tool(yum groupinstall "​Development tools"​)과 ruby는 미리 깔려 있어야 한다. Linuxbrew 홈페이지를 참조하여 설치를 한 다음 brew doctor를 실행하니 git를 업데이트하라는 메시지가 나온다. brew install git를 하면 glibc, binutils 등 git가 의존하는 패키지가 자동적으로 설치될 것이다. 다음으로는 공식 문서에서 요구하는 prerequisite인 java(6+), perl(5.8.8+), ​**python(2.7.3+)**, R(2.11.1+ with PNG support), ​**gcc(4.7+)**, curl 및 wget이 설치되어 있는지 확인하라. gcc -v를 실행하면 linuxbrew를 통해서 5.3.0이 설치되었음을 확인할 수 있다. 현재 내가 쓰는 서버의 패키지 설치 상황은 [[my_brew_list|여기]]를 참조하라.
  
 === Python === === Python ===
Line 27: Line 27:
   $ brew install open-mpi   $ brew install open-mpi
   $ pip install --upgrade pip   $ pip install --upgrade pip
-  ​ + 
-[[https://​www.continuum.io/​downloads|Anaconda]]를 이용하면 최고한 파이썬 실행 환경은 2.7대로 올릴 수 있다.+=== Linuxbrew에 의존하기 싫다면? === 
 +Linuxbrew가 제공하는 gcc는 버전이 5.x대라서 다소 높은 감이 없지 않다. Linuxbrew 없이 gcc의 버전을 높이려면 소스에서 직접 빌드하거나 devtoolset를 사용하는 방법이 있다. ​[[https://​www.continuum.io/​downloads|Anaconda]]를 이용하면 최고한 파이썬 실행 환경은 2.7대로 올릴 수 있다. ​
  
 === Prerequisite 설치 === === Prerequisite 설치 ===
metamos_installation.txt · Last modified: 2017/03/24 08:38 by hyjeong